Topology:
To make VPC5 communicate with VPC6, lets add static route on both the Switches. VPC5 is in vlan10 and VPC6 is in vlan20.
VPC5
IP: 172.17.10.1/24
GW: 172.17.10.100
VPC6
IP: 172.17.20.1/24
GW: 172.17.20.100
irb.10 = 172.17.10.100
irb.20 = 172.17.20.100
Refer previous blogs in relation to vlan creation and irb interface configuration.
vlan configuration: https://aaqiltech.blogspot.com/2023/02/creating-vlans-on-juniper-switch-vqfx.html
root@vqfx-re# show
HR {
vlan-id 10;
l3-interface irb.10;
}
default {
vlan-id 1;
}
{master:0}[edit vlans]
irb interface configuration: https://aaqiltech.blogspot.com/2023/04/creating-irb-interfaces-vqfx-eve-ng.html
root@vqfx-re# show
unit 10 {
family inet {
address 172.17.10.100/24;
}
}
{master:0}[edit interfaces irb]
Let's assign IP address for p2p interfaces on both switches
root@vqfx-re# set interfaces xe-0/0/10 unit 0 family inet address 1.1.1.1/24
root@vqfx-re# set interfaces xe-0/0/10 unit 0 family inet address 1.1.1.2/24
root@vqfx-re# show
unit 0 {
family inet {
address 1.1.1.1/24;
}
}
{master:0}[edit interfaces xe-0/0/10]
root@vqfx-re# show
unit 0 {
family inet {
address 1.1.1.1/24;
}
}
{master:0}[edit interfaces xe-0/0/10]
Lets configure static route on both switches
root@vqfx-re# set routing-options static route 172.17.20.0/24 next-hop 1.1.1.2
root@vqfx-re# set routing-options static route 172.17.10.0/24 next-hop 1.1.1.1
root@vqfx-re# show
static {
route 172.17.20.0/24 next-hop 1.1.1.2;
}
{master:0}[edit routing-options]
Verify the the static route configured
root@vqfx-re> show route
inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
172.17.20.0/24 *[Static/5] 00:11:45
> to 1.1.1.2 via xe-0/0/10.0
Now both the PCs should be able to communicate with each other.
0 Comments